Difference between revisions of "Participle"

From Botdom Wiki
Jump to: navigation, search
(inactive project)
Line 11: Line 11:
 
| license = [[Free software]] ([[GNU General Public License|GPL]])
 
| license = [[Free software]] ([[GNU General Public License|GPL]])
 
}}
 
}}
 +
{{DeadProject|norec=yes]
 +
 
'''participle''' is a [[Ruby]] bot created by {{deviant|incluye}}. Its syntax is similar to the [https://github.com/cinchrb/cinch Cinch] IRC bot. It requires Ruby 1.9.
 
'''participle''' is a [[Ruby]] bot created by {{deviant|incluye}}. Its syntax is similar to the [https://github.com/cinchrb/cinch Cinch] IRC bot. It requires Ruby 1.9.
  

Revision as of 00:08, 15 July 2015

participle
Participle.png
running participle!
Developer(s): incluye
Programming language: Ruby
Development state: Active
Source model: Open source
Last preview release: 1.4.0 (Feb 23, 2011)
License type: Free software (GPL)


{{DeadProject|norec=yes]

participle is a Ruby bot created by incluye. Its syntax is similar to the Cinch IRC bot. It requires Ruby 1.9.

Features

  • Full-fledged extension system
  • Basic permissions management
  • Dynamic loading/unloading of modules
  • Queued logging (superbot-impervious!)
  • Actually pretty okay setup
  • Cross-platform (thank you, Ruby!)

Downloads

  • participle v1.4.0 tar.gz | zip
    • Backported to Ruby 1.8, using Iconv in stdlib for encoding conversion.
  • participle v1.3.0 tar.gz | zip
    • Command-line interface (Unix only)
    • Theming system for the logs!
  • participle on GitHub (bleeding-edge) tar.gz | zip
    • Unless you have very good reason to be using a previous version of participle, get the latest version from the repo. The bot is under very active development.

For older releases, see the downloads page on Github.

Documentation

See the extensive RDoc documentation online.